update

There is a big issue with the Gutenberg editor on WordPress 5.0+. Upon updating to the recent version of Gutenberg, there is an issue that doesn’t allow you to save or publish posts. An “Updating Failed” or “Publishing Failed” error. keeps popping up.

2018-06-30_21-13-01

Screenshot of the inspector:

2018-06-30_21-07-22

The Problem

Error in plain text for reference:

  • The hook name can only contain numbers, letters, dashes, periods and underscores.
    index.js?ver=153025076:1

The problem seems to be that if another installed plugin uses wp.hooks.addAction() (such as Advanced Custom Fields) then editing will break.

Also, there have been reports that SSL/HTTPS is breaking the saving if in General the URL’s are not updated to https://

Known Plugin Compatibility issues

Here we keep a list of WordPress plugins that are known to have conflicts with the Gutenberg editor, this list is for reference only so that you can know which plugins to avoid when working with Gutenberg.

  • Advanced Custom Fields
  • WP Cerber Security solved since 7.5
  • Space Admin Theme solved since 1.0.5

Troubleshooting

Since WordPress 5.1 there are fewer reports of this issue so if you haven’t updated the core so far, make sure you do it.

The same goes with WordPress plugins, in most of the cases plugin authors fixed these compatibility issues in their newest version.

Classic WordPress editor

Optionally, if updating your WordPress installation and active plugins don’t work, as well as fixing https compatibility errors, you can always revert back to the classic WordPress editor with a custom plugin.

Are you also unable to save posts with the Gutenberg editor? Let us know in the comments so that we can try to resolve the issue together.

Was this post helpful?

    Leave a Comment

    We use cookies to provide an awesome experience on our website. By continuing to use this site, you agree to our tasty cookies.
    🍪 Accept Cookies
    Privacy Policy